Solutions

How-To fix the SBM 11.7.1 installer to install without looking for MS Visual C++ 2010 SP1?



ID:    S143596
Published:    12 November 2021

Product(s)

  • SBM
 

Description

Prior versions of SBM require the MS Visual C++ 2010 SP1 redistributable.  We have corrected this in SBM 12 which includes new FIPS-compliant software.
 
However, we have released SBM 11.7.1 Hotfix 6 that no longer requires the older 2010 redistributable for those that are unable to upgrade at this time.  Do note that due to the rules of FIPS compliance, this hotfix cannot be consider FIPS-compliant.
 
See the resolution for install SBM 11.7.1 without the C++ 2010 redistributable.
 

Resolution

 

How-To Install SBM 11.7.1 withoutMicrosoft Visual C++ 2010 SP1 Redistributable Package (x64)

  1. Download the SBM 11.7.1GA Installation zip file and extract it to a folder.
  2. Modify the following file:

    ..\BM11_7_1\SBM\disk1\Suite_x64\setup.ini

    Remove the following line and save file:
    PreReq18=Microsoft Visual C++ 2010 SP1 Redistributable Package (x64).prq

  3. Run the installer.  After the Install is complete and prior to opening SBM Configurator, do the following:

    *  Apply SBM 11.7.1 HF6
    *  Install the Microsoft Visual C++ Redistributable packages for Visual Studio 2015, 2017, 2019, and 2022

     
  4. Open up SBM Configurator and continue as normal.
 

Applies To

SBM 11.7

Rate this Solution

Find Answers

Type a question or describe what you are looking for below

My Recent Searches

Welcome kb sso

Additional Assistance

  • Submit a Case Online
  • FAQs